1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, is it this your first time on the forums?

    Visit the Beginner's Box

    Introduce yourself, read some of the ins and outs of the community, access to useful links and information.

    Dismiss Notice

[1865] Various Bugs (including the Flying Tree archer etc). Majorly Game Breaking

Discussion in 'Archive' started by EhRa, Jun 19, 2016.

Thread Status:
Not open for further replies.
  1. EhRa

    EhRa Ooooooof Staff Alumni Donator
    1. KRPG

    Messages:
    810
    Category; Kag Client/ Server
    Operating System; Mac, But the glitch has been shown on multiple other systems.
    Build Number: 1865, but again has been present on other builds.

    Description;


    The various bugs, including being able to climb a tree as archer and start flying for a short distance, moving between the red barrier, animation glitches (both of the arrow aim animation and the keg animations), and various other glitches with other blobs.

    Step to Reproduce;

    Enter an online server.
    Quit then enter a challenge or save the princess single player mode.
    At this point, my singleplayer glitches out
    20160611150237_1.jpg

    Then, when entering a server, the various glitches noted above start to work. FYI, not reporting the sandbox glitches but the multiplayer glitches as seen below in proof.

    Proof;

    20160619115349_1.jpg 20160619115403_1.jpg 20160619115417_1.jpg 20160619121822_1.jpg 20160619120854_1.jpg 20160619122333_1.jpg
    Also when changing class and still invicible, the said class stays white as if a ghost and does not die for ages.
    I'll get some more screen once I test it more.

    Video Thanks to Sean.


    Other people this glitch has been reproducible, other it has not.

    Kazaco: Resolved
     
    Last edited by a moderator: Jul 13, 2016
    Kazaco97 and PUNK123 like this.
  2. epsilon

    epsilon Assonist THD Team Forum Moderator Donator Tester
    1. Gather Oceania
    2. KAG World Cup 2018

    Messages:
    505
    I have tried to reproduce this glitch but it hasn't worked.
    Singleplayer used to glitch for me but now it doesn't.
    I downloaded FunATuns factions and went onto save the princess and i spawned as if it were factions.
    So i assume it might be due to some mods.
     
    Last edited: Jun 20, 2016
  3. makmoud98

    makmoud98 You are already DEAD Forum Moderator Staff Alumni Tester

    Messages:
    586
    This is a rare bug that basically just mixes around the blob ids and that is why you see all these random blobs in a sandbox map. What you see here is all the bushes, and trees that are supposed to be there, are now some other blob. No one has found a way to reproduce this yet. Its one of those things that just happen and no one really knows how to fix it because it is such a rare occurrence.
     
    PUNK123 likes this.
  4. SlayerSean

    SlayerSean FYI: it's pronounced "seen"

    Messages:
    191
    I managed to repeatedly reproduce this using method provided in OP. Recorded it to make it more clear what happens and how to do it:

     
    EhRa likes this.
  5. EhRa

    EhRa Ooooooof Staff Alumni Donator
    1. KRPG

    Messages:
    810
    My actual post was not referring to the sandbox blob glitches, but more to what happens after. I'm simply stating that once the sandbox/challenges etc glitches out like that, it allows things such as red barrier walking, archers flying after climbing trees and various other animation glitches.
     
  6. toffie0

    toffie0 is sweeter than you <3 Global Moderator Forum Moderator Tester

    Messages:
    345
    20160620173931_1.jpg snip_20160620174750.png


    If you cant tell by the screen shots, Ive been able to reproduce this bug. If you dont get it the first time try again if your trying to test it. First time I wasnt able to then I tried again and was able to non-stop.
     
    EhRa likes this.
  7. Geti

    Geti Please avoid PMing me (poke a mod instead) THD Team Administrator Global Moderator

    Messages:
    3,730
    I've passed this on to MM; I'm not confident to touch the code that's probably causing this. It's to do with assets being loaded/unloaded and the asset cache getting corrupted - which is why things get "weird" when you join in sandbox (its looking in the old asset cache but spawning new assets). Hopefully this helps him debug the issue properly.
     
    Vampire, SirDangalang, Magmus and 2 others like this.
  8. MM

    MM THD Team THD Team Administrator Global Moderator

    Messages:
    327
    Should be fixed in the next patch.
     
Thread Status:
Not open for further replies.