1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, is it this your first time on the forums?

    Visit the Beginner's Box

    Introduce yourself, read some of the ins and outs of the community, access to useful links and information.

    Dismiss Notice

An error occurred while trying to create an Enet server host

Discussion in 'Help' started by DragonShark, Jan 20, 2016.

Mods: makmoud98, Mazey
  1. DragonShark

    DragonShark The one post after the other. Donator

    Messages:
    390
    So I wanted to make my own server, I set up the whole autoconfig, did the seclevs, mapcycle, ports (50301, 50238) and I set up my IP.
    Yet I still get this message when I try to start up my server, but... When I make the IP blanc or remove it, it works then, but doesn't show up in the server list, here's what I get:
    How do I fix this?
    [​IMG]
     
  2. Furai

    Furai THD Team THD Team Administrator

    Messages:
    3,118
    Don't bind your IP and make sure you have ports forwarded properly.
     
  3. makmoud98

    makmoud98 You are already DEAD Forum Moderator Staff Alumni Tester

    Messages:
    586
    First you need to open port 50301 on your router. You can google how to do this as the procedure varies from router to router. If you can't find anything, you can try using this website
    http://portforward.com/english/routers/port_forwarding/routerindex.htm

    What do you mean "when I make the IP blanc or remove it"?

    Also the issue with that error you have there just means that you have either 2 kag servers open, or you are playing singleplayer in kag (which will use port 50301)
     
  4. DragonShark

    DragonShark The one post after the other. Donator

    Messages:
    390

    Attached Files:

  5. makmoud98

    makmoud98 You are already DEAD Forum Moderator Staff Alumni Tester

    Messages:
    586
    try to connect to your own server by using direct connect. in the ip box type 127.0.0.1:50301 and then the password below. I have a feeling that others are able to join your server.
     
  6. DragonShark

    DragonShark The one post after the other. Donator

    Messages:
    390
    Okay well Makmoud the server works, and I can connect, but there's another problem now.
    I don't get the Admin button. I do have a purple name instead of an orange one, I can freeze people and stuff, but further more I can't really do anything.

    Here's a vid explaining it:
    https://youtu.be/4Gl60L5EkhI
    --- Double Post Merged, Jan 27, 2016, Original Post Date: Jan 26, 2016 ---
    Anyone here?
     
  7. Furai

    Furai THD Team THD Team Administrator

    Messages:
    3,118
  8. DragonShark

    DragonShark The one post after the other. Donator

    Messages:
    390

    Attached Files:

  9. bunnie

    bunnie Haxor Tester

    Messages:
    1,310
    u didnt add yourself into superadmin.cfg lol
     
  10. Mazey

    Mazey Haxor Global Moderator Forum Moderator Staff Alumni Donator Official Server Admin

    Messages:
    1,912
    It's a new/previously unknown bug, you're admin but you don't get the admin panel. Someone else had this issue too a few days ago, tried both rcon and seclevs.
     
  11. DragonShark

    DragonShark The one post after the other. Donator

    Messages:
    390
    Yeah it's weird, would be nice if the devs could solve this.
     
  12. Diprog

    Diprog Bison Rider Tester
    1. FUN Servers

    Messages:
    149
    Emm, what? He needs to connect by his ip and port, not by local ip, so he can check if it's a port forwarding problem
     
    Fuzzle likes this.
  13. makmoud98

    makmoud98 You are already DEAD Forum Moderator Staff Alumni Tester

    Messages:
    586
    nono, he implied that people were able to join because he could freeze them. this issue is that some people cannot connect to their own server with a public ip address for some reason. i think i read somewhere once that it is because of a redirect loop or something.
     
Mods: makmoud98, Mazey