1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, is it this your first time on the forums?

    Visit the Beginner's Box

    Introduce yourself, read some of the ins and outs of the community, access to useful links and information.

    Dismiss Notice

Bug Reports

Discussion in 'Groups' started by Aphelion, Jul 1, 2014.

  1. Aphelion

    Aphelion Wunderkind Donator
    1. Aphelion's Roleplay

    Messages:
    180
    Here you may post bug reports, if you've found a major exploit please send me a private message instead.

    Please use this format:
    Code:
    Summary:
    How to recreate:
    Media: 
     
  2. ironhead31

    ironhead31 Catapult Fodder

    Messages:
    0
    Hey, aphelion, i cannot enter server since update 1.7.12.

    Idk if here is the correct place to write this, soo, if isn't,sorry

    Everytime i try to join, my KAG crashes , showing up error messages, etc.

    I've tried to:

    try again multiple times
    delete roleplay folder
    send a error report

    Thanks to your attention!

    Ironhead
    (sorry any english errors)
     
  3. Aphelion

    Aphelion Wunderkind Donator
    1. Aphelion's Roleplay

    Messages:
    180
    Resolved.
     
  4. Sasquash

    Sasquash Zicronium Merchant Donator

    Messages:
    108
    Summary: Having Join issues
    How to recreate: When I Join the server, it loads in but the race select never shows up, chat loads, and i'm stuck with an elipses blinking at me from where the team menu should be.
    Media: 2014-10-21_00003.jpg This is all I see aside from chat showing the server announcements and ... all the time

    I tried using bandicam to record a few things.
    1. I was headless on Zombie Fortress.
    2. Instead of getting to the map it just crashed and killed my recording.

    How do I get around this?
    When can we expect it to be back up?
     
    Last edited: Oct 21, 2014
  5. Duke_Jordan

    Duke_Jordan King Arthur's Knight Donator
    1. Aphelion's Roleplay

    Messages:
    145
    The issue regarding the Infamous Roleplay Map loading bug happens every so often, no fix you can do on your end of things as it is all server-side, best to wait for Aphelion to restart the server (It would most likely happen within 24-hours)

    The reason your headless on zombie fortress is due to a bug however it is fixable on your end of things, Try Re-installing the mod and that should fix it.
     
  6. builder321

    builder321 Shipwright

    Messages:
    8
    Server broke in the update you just released, nobody can join a team xD
     
  7. Duke_Jordan

    Duke_Jordan King Arthur's Knight Donator
    1. Aphelion's Roleplay

    Messages:
    145
    This glitch happens every once in awhile, Aphelion will restart the server when he gets a chance.

    Resolved for now.
     
    Last edited: Oct 30, 2014
  8. TeHWooF

    TeHWooF Catapult Fodder

    Messages:
    0
    The server appears to be stuck on "Waiting for server to load map..." when trying to connect to it.
     
  9. Duke_Jordan

    Duke_Jordan King Arthur's Knight Donator
    1. Aphelion's Roleplay

    Messages:
    145
    Will be back up within a few hours in most cases of this bug occurring.
     
  10. king-george

    king-george Bison Rider Staff Alumni Tester

    Messages:
    284
    Summary: When in elf race(archer), you press down, and you are supposed to be shown with a kind of bush... It does that, but when you do that a flying satchel appears.
    How to recreate: Just join the elf race and do the archer class, then press down.
    Media: None, because it is easy to recreate.
     
  11. Duke_Jordan

    Duke_Jordan King Arthur's Knight Donator
    1. Aphelion's Roleplay

    Messages:
    145
    Noted.
     
  12. Sasquash

    Sasquash Zicronium Merchant Donator

    Messages:
    108
    Summary: RP is causing crashes
    How to recreate: Join RP, game lags out and then Kag outright crashes.
    Suggestions: Remove Winter. It has a few fundamental flaws one of which iirc was that it ustilized a runnerhead.as file. Its a cute texture pack but interferes too much with everything else, adds a ton of lag. I don't see the iconic breath so i'm assuming that script was removed but to save on lag, removing KAGcoldwill probably save the time and effort.
    Media:
     
  13. Aphelion

    Aphelion Wunderkind Donator
    1. Aphelion's Roleplay

    Messages:
    180
    It's something completely different, something caused by screwy netcode; the infamous loading bug, which requires server restart.

    Fyi, I'm not using that mod per se, I've only implemented certain crucial files, which are images only so it is not causing lag. By the way, a full implementation of seasons will be coming to Roleplay soon.
     
    Last edited: Dec 10, 2014
  14. Vermilicious

    Vermilicious Ballista Bolt Thrower

    Messages:
    232
    KAG freezes for me today when I try to join the Roleplay server. The client loads the map, but then nothing happens, and the cursor is frozen. The server browser reports that people are playing there though.
     
  15. Aphelion

    Aphelion Wunderkind Donator
    1. Aphelion's Roleplay

    Messages:
    180
    Clear your Mods folder.
     
  16. orange_otter_01

    orange_otter_01 Drill Rusher

    Messages:
    75
    if you are holding anything that floats with the satchel (quiver) aswell, i noticed it when i was trying to hide a stolen chest from a passerby XD
    --- Double Post Merged, Jan 10, 2015, Original Post Date: Jan 10, 2015 ---
    another bug! is not serious

    i was holding a hand cannon and was standing on a ladder slightly above the dwarf spawn,
    ex:
    :chest: = spawn

    :archer:
    :ladder:
    :chest:

    i had 80 round shot in my inven.
    then i noticed these copper arrows spawning where i was standing, just spawning, and spawning... and spawning... and spawning... and etc.
    sorry i didnt think of a screenshot or vid at the time::(:

    is not a serious bug (who wants copper arrows anyways?) but thought i might as well tell ya
     
  17. Vermilicious

    Vermilicious Ballista Bolt Thrower

    Messages:
    232
    Planting seeds not working

    I'm not sure this has been reported yet, but since the last KAG patch, I think, "planting" seeds cause trees to become invisible and not growing. You can still whack them though. To get the trees (and I assume other plants) to grow, you have to drop the seed on the ground instead - like you had to a long time ago before they added planting.

    Triangles too big?

    This might be an old topic, but the triangles are buggy. I think it's because they're a bit too big; a bit larger than half a block. For instance, if you place these triangles next to doors, you'll have trouble passing through the door. Sometimes you can, other times not. If you have a triangle at both sides (i.e. above and below), you can't pass at all.
     
  18. king-george

    king-george Bison Rider Staff Alumni Tester

    Messages:
    284
    I submitted my head to Blowjob, but it doesn't appear on me. I checked the files in the mod, it's not there... The latest update says it has my head.
     
    Last edited: Jan 11, 2015
  19. Aphelion

    Aphelion Wunderkind Donator
    1. Aphelion's Roleplay

    Messages:
    180
    They are buggy because they are blobs, not actual tiles. This is not something that can be resolved unless modders are able to make full fledged tiles.
     
  20. lare290

    lare290 Builder Stabber

    Messages:
    27
    When ever I go to your server, it shows my character as errored and freezed, and I can not move. Sometimes it also shows all blocks with function, like hall and doors, as errored and freezed also. I have deleted mod folder million times and still it wont help. I like your server but now it just wont let me play there..