1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, is it this your first time on the forums?

    Visit the Beginner's Box

    Introduce yourself, read some of the ins and outs of the community, access to useful links and information.

    Dismiss Notice

Linux Engine KAG Fullscreen refresh rate

Discussion in 'Bug Reports' started by mesouug, Aug 21, 2020.

  1. mesouug

    mesouug Bison Rider

    Messages:
    1
    Category: KAG Client

    OS: Linux

    Build number: 3338

    Description: When starting game in fullscreen mode on certain monitors game starts in 30hz refresh rate. Some resolutions are started interlaced. Upon inspection I noticed that this problem is monitor dependent. Looks like game selects smallest possible refresh rate with Vsync according to EDID of monitor. Issue is old and I'm pretty sure it's 3+ years old.

    Steps to reproduce:
    • Start KAG in fullscreen mode
     
  2. Asu

    Asu THD Team THD Team Forum Moderator

    Messages:
    1,579
    I think this is reproduces only on nvidia proprietary driver and that this is due to the broken behavior of irrlicht, but that's unfortunately not something that can be fixed easily.
    There is a build in the works now with major engine reworks which uses SDL2 for windowing which is way more reliable on linux regarding fullscreen and fixes this issue, but there is no ETA for release.
    A workaround you can try is to set the game to windowed, enter your resolution manually in the settings, and use a WM/DE specific way to force a window to fullscreen. This is possible on KDE in some window settings reachable from the contextual menu when right clicking the title bar. In most tiling WMs it's possible by just using the usual fullscreen shortcut.
     
    blackjoker77777 likes this.
  3. mesouug

    mesouug Bison Rider

    Messages:
    1
    Hi there.
    I did more testing and bug is reproduced on Intel HD as well. I did try to force fullscreen with following command: wmctrl -r :SELECT: -b toggle,fullscreen but it doesn't really work on KAG window. Other apps works well.

    Anyway thanks for heads up. Will wait for SDL update.