1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, is it this your first time on the forums?

    Visit the Beginner's Box

    Introduce yourself, read some of the ins and outs of the community, access to useful links and information.

    Dismiss Notice

Gamemode mods causing server issues.

Discussion in 'Help' started by MrCupcakes, Jul 11, 2018.

Tags:
Mods: makmoud98, Mazey
  1. MrCupcakes

    MrCupcakes Catapult Fodder

    Messages:
    3
    Whenever i try to use a gamemode mod on my server, it doesn't work. Other mods do.
    More specifically, whenever I or another player try to join the server we get an error compiling server scripts.
    When launching the server, it returns LOTS of errors finding scripts, reading them, and relocating them.
    I do have the mod in my mods.cfg, and the gamemode set in my autoconfig.
     
  2. Blubahub

    Blubahub Builder Stabber Tester
    1. [MxA] Community

    Messages:
    81
    Hmm...

    Oh, I know [potentially] why! Do you use runlocalhost.bat for hosting? Because if you do and you try to get someone to join it through direct IP connect (Connect to...), then for some reason, the other player will join WITHOUT downloading the mod... Very odd, I know. If you do use it then switch over to dedicatedhost.bat - that is the server software used for multiplayer (private and public)..!
     
  3. 8x

    8x Elimination Et Choix Traduisant la Realité Forum Moderator Official Server Admin Tester
    1. The Young Blood Collective - [YB]

    Messages:
    1,295
    What mod is it that you're trying to host? That sounds as if the mod has errors within its scripts.
     
  4. MrCupcakes

    MrCupcakes Catapult Fodder

    Messages:
    3
    I am trying to use zombie fortress plus, though i have also tried roleplay to see if it was that mod alone. It still had the same error except with a different script when i ran roleplay.
    --- Double Post Merged, Jul 11, 2018, Original Post Date: Jul 11, 2018 ---
    I was and am using dedicatedserver.bat, not local. Everyone downloads the mods when they join, and then they go through the entire connecting process, but it gives the error after all of that just before they enter.
     
  5. Blubahub

    Blubahub Builder Stabber Tester
    1. [MxA] Community

    Messages:
    81
    @MrCupcakes You did set you're sv_gamemode (in autoconfig) to Zombie Fortress Plus, right?
     
  6. MrCupcakes

    MrCupcakes Catapult Fodder

    Messages:
    3
    It gives me the errors if i have the mod enabled, both with it enabled in autoconfig and not enabled.

    This is the last couple of lines:

    [10:14:28] Adding map to cycle 'Maps/zf_22.png'
    [10:14:28] Adding map to cycle 'Maps/zf_23.png'
    [10:14:28] Adding map to cycle 'Maps/zf_24.png'
    File open error: No such file or directory

    [10:14:28] File not found Maps/zf_23.png, searching matches...
    [10:14:28] Best match ../Mods/ZFM+1.6.6a/Maps/zf_23.png
    [10:14:28] LOADING PNG MAP ../Mods/ZFM+1.6.6a/Maps/zf_23.png
    [10:14:28] Checking if update available
    APP: downloading file http://update.kag2d.com/1/win32-client-release/App//version.txt
    Downloading http://update.kag2d.com/1/win32-client-release/App/version.txt...
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    51 136k 51 71802 0 0 35901 0 0:00:03 0:00:02 0:00:01 42969

    CURL Error: Timeout was reached
    APP: error downloading file to ../Cache (err 28)
    [10:14:30] Restarting rules script: ../Mods/ZFM+1.6.6a/Rules/zombies_Rules.as
    [10:14:40] Zombies: 0 Extra: 0
    [10:14:40] Portal Zombies: 0 Extra: 0
    [10:14:40] Migrants: 0 Extra: 0
    [10:14:50] Zombies: 0 Extra: 0
    [10:14:50] Portal Zombies: 0 Extra: 0
    [10:14:50] Migrants: 0 Extra: 0
     
    Last edited: Jul 15, 2018
Mods: makmoud98, Mazey