1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, is it this your first time on the forums?

    Visit the Beginner's Box

    Introduce yourself, read some of the ins and outs of the community, access to useful links and information.

    Dismiss Notice

Trench Run KAG OSX Users - Post Current Bugs Here [KAG:1714][TR:7]

Discussion in 'Announcements' started by Geti, Jan 7, 2016.

  1. Geti

    Geti Please avoid PMing me (poke a mod instead) THD Team Administrator Global Moderator

    Messages:
    3,728
    Hey Everyone!

    We've been getting a lot of reports of bugs with the OSX version - but not much info on what they actually are or how to fix them! If you have current bugs on OSX, please post them here in the following format:
    • Short Bug Description (30-150 words). Please be as descriptive as you can.
    • OSX Version Number
    • Any Crash Report in the case of a crash bug. This helps us know which function call led to the crash, but its only part of the puzzle.
    • Your console log file from an example run of the game (found in KAG.app or TR.app, it can be opened like a normal folder) Upload directly to your post or to a site like pastebin.com. You may include it as part of your post but only inside spoiler tags. The log in question should be called console-date.txt where the date is in yy-mm-dd-hh-mm-ss format.
    • Any screenshots of the issue if it is a rendering bug or similar. Please only post bugs that you think are platform related here (not bugs that you hear happen on windows as well).
    • If you have found a workaround for a bug, please include that information as well.
    Notes: Some users have reported not having a logs folder inside their .app folder at all! Please create this folder by hand if you can and logs should start to show up there. We're looking into possible workarounds for this. We need the console log file in most cases for proper debugging.

    Bugs that happen only in one game are welcome, but bugs that happen in both games are extra-interesting. Please do not post old bugs.

    We look forward to helping you out!
    Cheers,
    Max
     
  2. Asu

    Asu THD Team THD Team Forum Moderator

    Messages:
    1,567
    Bint likes this.
  3. MoxyFoxy

    MoxyFoxy Shipwright
    1. [Server] Sandbox Reborn

    Messages:
    20
    • Open up KAG through Steam. Open main game from launcher. Click Multiplayer button. Proceed to browse servers. Click on random server, proceed to hit play on random server. Game loads blobs, finishes loading blobs, goes to loading rules. When it's about three-quarters through with the rules and you think it's about to go to the next connecting stage-KAG quits. This happens in multiplayer or single player, no matter what server I choose. First few times it happened I assumed it had something to do with my ping or connection, but as Kag and the servers load just fine for me and this happens without fail every time the same way-I don't think that's the case anymore. This bug has been happening for roughly two weeks now.
    • OS X version 10.8.5
    • Zipped attachment is a word document with my crash report for kag.
    • Not entirely sure how to upload my console log file, so if someone could coach me on how to do that that'd be great. Also I may or may not have no idea how to put stuff in spoilers.
    • I did manually create the logs folder, stuff is starting to appear in it.
    I also posted in the Bug Reports for KAG, I think that post is actually more in-depth than this one, I'm sure you've already seen it though.
    --- Double Post Merged, Jan 7, 2016, Original Post Date: Jan 7, 2016 ---
    @Teodor1
     

    Attached Files:

  4. Bint

    Bint Bison Rider

    Messages:
    536
  5. MoxyFoxy

    MoxyFoxy Shipwright
    1. [Server] Sandbox Reborn

    Messages:
    20
  6. KArth

    KArth Ballista Bolt Thrower

    Messages:
    59
    MM likes this.
  7. internaldogmunch

    internaldogmunch Catapult Fodder

    Messages:
    1
    I'm having an issue where whenever I try to make KAG fullscreen (any resolution) My game starts to a black screen
     
    cdaringe and Bum_Bleed like this.
  8. Bum_Bleed

    Bum_Bleed Builder Stabber

    Messages:
    16
    Games with bug
    KAG
    Trench Run
    Description
    Black screen when in fullscreen on any resolution. No UI response, sound, etc. Must force quit to exit.
    Started happening since the new build (Resolution fixes). Does not happen on Windows [10].
    OSX Version
    10.11.2
    MacBook Pro (Retina, Mid 2012)
    No crash report
    Console Logs

    In attachment

    Thanks :)
     

    Attached Files:

  9. Konoko

    Konoko Shark Slayer

    Messages:
    21
    Games
    Trench Run
    Description
    Can't use the shift key (same with caps lock). can't login as Konoko
    OSX Version
    10.10.5
    Keyboard
    AZERTY (tried to restart app with US keyboard in preferences)
    Attachment
    Tried with Keyboard Viewer; "command" key is pressed to take screenshot.
    Konokant.png

    Edit :
    didin't found anything about «keycode» or «shift» in logs anyway login ins't case sensitive so my login issue was a qwerty/azerty issue ::):
     
    Last edited: Jan 16, 2016
  10. Eden001

    Eden001 Catapult Fodder

    Messages:
    8
    OSX - Black Screen
    Ok, so i got King Arthur's Gold for Mac and i went into the launcher and changed the settings from 1280x900 to 1600x900 (My monitor Resolution) and set it to full screen. When i launch the game the whole screen turns black. I can't do anything but restart my computer to get out of this screen.

    OS X Number - OS X Yosemite Version 10.10.5
     
  11. Geti

    Geti Please avoid PMing me (poke a mod instead) THD Team Administrator Global Moderator

    Messages:
    3,728
    MM's going to be getting a mac to work on these issues. Seems like the biggest one in KAG is issues with fullscreen. I'm not sure why you'd be getting a black screen (and why this would only be happening now) but we'll be looking into it as soon as we can. Until then the simplest workaround is to play windowed.
    In TR the keyboard entry issue is huge, but we're having trouble tracking down what causes this one as well. Debugging both will be simpler once MM has proper hardware to test on - nagging him directly will make sure its on his TODO list, as currently OSX issues rate quite poorly in his priorities.
     
    Asu, Theodore433, Konoko and 3 others like this.
  12. Ranmage

    Ranmage Builder Stabber

    Messages:
    62
    Edit:
    I fixed it. At last. All i needed was a newer version of OS X.
    Game:
    KAG
    Description:
    Upon opening kag, kag instaquits.
    or KAG goes through the process of a super quick seppuku
    OSX version? 10.6.8
    LOGS
    Process: launchd [919]
    Path: /Users/prdtesting/Desktop/Kag copies/corrupted shit/KAG.app/Contents/MacOS/KAG
    Identifier: launchd
    Version: ??? (???)
    Code Type: X86 (Native)
    Parent Process: launchd [85]

    Date/Time: 2016-02-10 19:53:31.817 +0200
    OS Version: Mac OS X 10.6.8 (10K549)
    Report Version: 6

    Interval Since Last Report: 93521 sec
    Crashes Since Last Report: 3
    Per-App Crashes Since Last Report: 2
    Anonymous UUID: 462FB03E-CDE5-4844-BD81-4289E60ADC5C

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x000000008fe01030
    Crashed Thread: Unknown

    Backtrace not available

    Unknown thread crashed with X86 Thread State (32-bit):
    eax: 0x00000000 ebx: 0x00000000 ecx: 0x00000000 edx: 0x00000000
    edi: 0x00000000 esi: 0x00000000 ebp: 0x00000000 esp: 0x00000000
    ss: 0x0000001f efl: 0x00010202 eip: 0x8fe01030 cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000000
    cr2: 0x8fe01030

    Binary images description not available


    Model: MacBook3,1, BootROM MB31.008D.B00, 2 processors, Intel Core 2 Duo, 2.2 GHz, 2 GB, SMC 1.24f2
    Graphics: Intel GMA X3100, GMA X3100, Built-In, 144 MB
    Memory Module: global_name
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x88), Broadcom BCM43xx 1.0 (5.10.131.42.4)
    Bluetooth: Version 2.4.5f3, 2 service, 12 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Samsung SSD 840 EVO 120GB, 111.79 GB
    Parallel ATA Device: MATSHITADVD-R UJ-857E
    USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8501, 0xfd400000 / 2
    USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8205, 0x1a100000 / 2
    USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x021b, 0x5d200000 / 3
    USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0x5d100000 / 2
    And i found this in the console
    2/10/16 7:59:36 PM com.apple.launchd.peruser.501[85] ([0x0-0x61061].KAG[950]) Job appears to have crashed: Segmentation fault
     
    Last edited: Feb 16, 2016
  13. Bint

    Bint Bison Rider

    Messages:
    536
    The Default folder is missing and localhost.as is in the Mods folder instead of the Scripts folder?
    Also, in runlocalhost.sh there should be a "./" at the beginning of the line, I think some of the other files need that too, as well as the ones in kag. Thanks @AsuMagic :rekt:
     
  14. Asu

    Asu THD Team THD Team Forum Moderator

    Messages:
    1,567
    @Devs, IIRC a compiler argument allows to list all symbol locations so you can find the matching called function when it crashed.
    Apparently, unless OSX fails into reporting registers, it seems that no (not inlined) function was called and that the crash was happening very early?
     
  15. Ranmage

    Ranmage Builder Stabber

    Messages:
    62
    It does. Instantly.
    I see the KAG pop up on my app bar for a brief moment, and disappear soon after.
    Takes about one second.
     
  16. thezteam7

    thezteam7 Builder Stabber

    Messages:
    10
    ^ I have the exact same issue, and my mac is somewhat new. I didn't used to have this problem, but it triggered right after the Christmas update.
     
    makmoud98 likes this.
  17. Bint

    Bint Bison Rider

    Messages:
    536
    Got this graphical bug before it crashed, although I think I may have seen it before without it crashing:
    screen-16-02-26-13-20-40.png
    Didn't get the crash report though because I forgot to create the Logs folder, the Screenshots folder was missing too.
    Also:
    screen-16-02-26-13-19-22.png
     
  18. cdaringe

    cdaringe Catapult Fodder

    Messages:
    1
    I found that the crash reports were not as referenced here, but I did manage to find them:
    Code:
    Library $ pwd
    /Users/cdaringe/Library
    Library $ fd KAG
    Application Support/CrashReporter/KAG_114C9251-F047-5A7C-A3CB-743AB2429058.plist
    Logs/DiagnosticReports/KAG_2018-10-06-232556_christophers-MacBook-Pro.crash
    Logs/DiagnosticReports/KAG_2018-10-06-232203_christophers-MacBook-Pro.crash
    Logs/DiagnosticReports/KAG_2018-10-06-231437_christophers-MacBook-Pro.crash
    Logs/DiagnosticReports/KAG_2018-10-06-222621_christophers-MacBook-Pro.crash
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app/Contents/MacOS/KAG
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app/Contents/MacOS/KAG.ico
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app/Contents/MacOS/Downloads/KAG_news
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app/Contents/MacOS/Base/Scripts/MapLoaders/GenerateFromKAGGen.as
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app/Contents/MacOS/Base/Rules/CommonScripts/KAG.as
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app/Contents/MacOS/Base/GUI/Fonts/KAGFont_small_x2.png
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app/Contents/MacOS/Base/Sounds/Music/KAGWorld1-2a.ogg
    ... a bunch of .ogg files
    Application Support/Steam/steamapps/common/King Arthur's Gold/KAG.app/Contents/MacOS/Base/Sounds/Music/KAGWorld1-1a.ogg
    Attached in the .zip file are 4 crash reports.

    I just bought the game tonight, and it has crashed so constantly I cannot play it. Any tips would be great! Thanks.
     

    Attached Files: