1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, is it this your first time on the forums?

    Visit the Beginner's Box

    Introduce yourself, read some of the ins and outs of the community, access to useful links and information.

    Dismiss Notice

KAG Problem starting KAGdedi (File not found) [SOLVED]

Discussion in 'Server Help' started by 50l3r, Jan 6, 2014.

  1. 50l3r

    50l3r Horde Gibber

    When i try to install KAG2D dedicated server, i have a problem executing the executable

    I have Ubuntu 12.04 64bits console.

    root@ks3094161:/home/kag2d# wget http://dl.kag2d.com/kagbeta-linux32-dedicated.tar.gz
    --2014-01-06 21:19:57--  http://dl.kag2d.com/kagbeta-linux32-dedicated.tar.gz
    Resolviendo dl.kag2d.com (dl.kag2d.com)... 2607:fd50:1:91b0::1840,
    Conectando con dl.kag2d.com (dl.kag2d.com)[2607:fd50:1:91b0::1840]:80... conectado.
    Petición HTTP enviada, esperando respuesta... 200 OK
    Longitud: 1552626 (1,5M) [application/octet-stream]
    Grabando a: “kagbeta-linux32-dedicated.tar.gz”
    100%[=====================================================================================================================================================================================================================================>] 1.552.626  1,77MB/s  en 0,8s
    2014-01-06 21:19:58 (1,77 MB/s) - “kagbeta-linux32-dedicated.tar.gz” guardado [1552626/1552626]
    root@ks3094161:/home/kag2d# tar -zxf kagbeta-linux32-dedicated.tar.gz
    root@ks3094161:/home/kag2d# cd kagbeta-linux32-dedicated
    root@ks3094161:/home/kag2d/kagbeta-linux32-dedicated# chmod +x KAGdedi
    root@ks3094161:/home/kag2d/kagbeta-linux32-dedicated# ./KAGdedi
    -bash: ./KAGdedi: No existe el archivo o el directorio
    My system dont found KAGdedi file

    When i execute this command
    apt-get install bluez-alsa:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386 gtk2-engines:i386 gtk2-engines-murrine:i386 gtk2-engines-oxygen:i386 gtk2-engines-pixbuf:i386 gvfs:i386 ibus-gtk:i386 libacl1:i386 libaio1:i386 libao4:i386 libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libattr1:i386 libaudio2:i386 libcanberra-gtk-module:i386 libcap2:i386 libcapi20-3:i386 libcups2:i386 libcupsimage2:i386 libcurl3:i386 libdbus-glib-1-2:i386 libesd0:i386 libfontconfig1:i386 libfreetype6:i386 libgail-common:i386 libgconf-2-4:i386 libgdbm3:i386 libgettextpo0:i386 libglapi-mesa:i386 libglu1-mesa:i386 libgphoto2-6:i386 libgphoto2-port10:i386 libgtk2.0-0:i386 libmpg123-0:i386 libncursesw5:i386 libnspr4:i386 libnss3:i386 libodbc1:i386 libopenal1:i386 libpulse-mainloop-glib0:i386 libpulsedsp:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-opengl:i386 libqt4-qt3support:i386 libqt4-script:i386 libqt4-scripttools:i386 libqt4-sql:i386 libqt4-svg:i386 libqt4-test:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 librsvg2-common:i386 libsane:i386 libsdl-image1.2:i386 libsdl-mixer1.2:i386 libsdl-net1.2:i386 libsdl-ttf2.0-0:i386 libsdl1.2debian:i386 libsqlite3-0:i386 libssl0.9.8:i386 libssl1.0.0:i386 libstdc++5:i386 libstdc++6:i386 libxaw7:i386 libxml2:i386 libxp6:i386 libxslt1.1:i386 libxss1:i386 libxtst6:i386 odbcinst1debian2:i386 xaw3dg:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libpam-winbind:i386
    I recieve this errors:

    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    E: No se ha podido localizar el paquete libgphoto2-6
    E: No se ha podido localizar el paquete libgphoto2-port10
    Help me people. I can't wait to serve this awesome game jeje :p
  2. 50l3r

    50l3r Horde Gibber

    i found solution execute "apt-get install ia32-libs"
    kaizokuroof likes this.
  3. kaizokuroof

    kaizokuroof Agkubuk|'Kaizokuroof' Cilobakil, Roofpointy Global Moderator Forum Moderator Donator Tester
    1. PumpkinStars - [Pk#] - Inactive

    Thanks for telling us the solution, many people don't but yeah, as you found out you needed all the libraries for 32 bit, before your server would run. I'm locking this thread and marking as solved, have a good one :thumbs_up:
  4. lavalord

    lavalord Haxor Staff Alumni Donator Tester

    This is now outdated. Most current distributions based on debian support multiarch. In which case you should follow this method.
    1. Check your foreign architectures:
    2. Code:
      sudo dpkg --print-foreign-architectures
    3. If i386 is not present:
      sudo dpkg --add-architecture i386
    4. Update your package list:
      sudo apt-get update
    5. Install 32-bit libraries required for KAG:
      sudo apt-get install libc6:i386 libstdc++6:i386 libglapi-mesa:i386 libgl1-mesa-glx:i386 libxxf86vm1:i386 libxext6:i386 libx11-6:i386 libfreetype6:i386 libgcc1-dbg:i386 libxdamage1:i386 libxfixes3:i386 libx11-xcb1:i386 libxcb-glx0:i386 libxcb-dri2-0:i386 libxcb1:i386  libdrm2:i386 libxdmcp6:i386
    xHKGx and kaizokuroof like this.