1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hey Guest, is it this your first time on the forums?

    Visit the Beginner's Box

    Introduce yourself, read some of the ins and outs of the community, access to useful links and information.

    Dismiss Notice

Linux KAG [Solved, pls delete] Can't load maps

Discussion in 'Server Help' started by Grendell100, Sep 25, 2017.

Thread Status:
Not open for further replies.
  1. Grendell100

    Grendell100 Bison Rider

    Messages:
    132
    EDIT: I fixed it by simply deleting everything and downloading new unchanged files. Apparently I did cause the issue myself. I have no idea how, though.

    Admins can delete this thread, it's pointless. Thanks!

    ____________________________________________________________

    Hello!

    This is the log:
    Code:
    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Mon Sep 25 17:47:12 2017 from 90.179.158.16
    root@EpicRaven:~# ./KAGdedi
    PID: 4615
    Starting in directory: /root/
    Engine
    File open error: No such file or directory
    
    Downloading checksums from http://update.kag2d.com/1/linux32-dedicated-release/App/version.txt
    
    Downloading http://update.kag2d.com/1/linux32-dedicated-release/App/version.txt...
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100 81041  100 81041    0     0  95366      0 --:--:-- --:--:-- --:--:--  191k
    file Downloads/App/version.txt
    Removing unused/moved files in ./Base
    
    Version file the same (key matches)
    
    Using file '/root/libJuxta_dedi.so'
    APP GameDLLInit
    
    INITIALIZING ANGELSCRIPT 2.27.1
    Game DLL initialized.
    Changing game working directory to '/root/Base/'
    Gathering all files from Base...
    [20:06:05] Config file not found '/root/Security/ignorelist.cfg'
    [20:06:05] Loading ignorelist from Base/Security/ignorelist.cfg
    [20:06:05] Loading ignorelist failed - file missing or corrupt. A blank ignorelist file will be generated for you.
    Running autostart script configure from Scripts/server_autostart.as
    [20:06:05] Creating video device...
    [20:06:05] Checking driver support...
    [20:06:05] Initializing new video device...
    [20:06:05] Irrlicht Engine version 1.8.0-alpha
    File open error: No such file or directory
    
    File open error: No such file or directory
    
    File open error: No such file or directory
    
    [20:06:05] Precaching files...
    Precaching files.
    [20:06:05] Precaching files end.
    Game version 2311
    [20:06:05] Controls loaded from ../Cache/player1.dat
    [20:06:05] Controls loaded from ../Cache/player2.dat
    [20:06:05] Controls loaded from ../Cache/player3.dat
    [20:06:05] Controls loaded from ../Cache/player4.dat
    [20:06:16] Loading rules Rules/Simple/gamemode.cfg
    [20:06:16] Loading game rules from Rules/Simple/gamemode.cfg...
    [20:06:16] Loaded team 0 'Blue Team'
    [20:06:16] Loaded team 1 'Red Team'
    [20:06:16] Loading rules Rules/Main/gamemode.cfg
    [20:06:16] Loading game rules from Rules/Main/gamemode.cfg...
    [20:06:17] Loading rules Rules/CTF/gamemode.cfg
    [20:06:17] Loading game rules from Rules/CTF/gamemode.cfg...
    [20:06:17] Loaded team 0 'Blue Team'
    [20:06:17] Loaded team 1 'Red Team'
    [20:06:18] Loading rules Rules/Sandbox/gamemode.cfg
    [20:06:18] Loading game rules from Rules/Sandbox/gamemode.cfg...
    [20:06:18] Loaded team 0 'Blue Team'
    [20:06:18] Loading rules Rules/WAR/gamemode.cfg
    [20:06:18] Loading game rules from Rules/WAR/gamemode.cfg...
    [20:06:18] Loaded team 0 'Blue Team'
    [20:06:18] Loaded team 1 'Red Team'
    [20:06:19] Loading rules Rules/TDM/gamemode.cfg
    [20:06:19] Loading game rules from Rules/TDM/gamemode.cfg...
    [20:06:19] Loaded team 0 'Blue Team'
    [20:06:19] Loaded team 1 'Red Team'
    [20:06:19] Loading rules Rules/Challenge/gamemode.cfg
    [20:06:19] Loading game rules from Rules/Challenge/gamemode.cfg...
    [20:06:19] Loaded team 0 'Blue Team'
    [20:06:19] Loaded team 1 'Red Team'
    [20:06:19] Initializing Game Script
    [20:06:19] ############ GAMEMODE WAR
    [20:06:19] Server created on 50301 (BUILD 2311)
    [20:06:19] Checking is server modded...
    [20:06:19] Whitelist inactive.
    [20:06:19] Config file not found '/root/../Security/blacklist.cfg'
    [20:06:19] Loading blacklist from Base/../Security/blacklist.cfg
    [20:06:19] Loading blacklist failed - file missing or corrupt. A blank blacklist file will be generated for you.
    [20:06:19] Config file not found '/root/../Security/ignorelist.cfg'
    [20:06:19] Loading ignorelist from Base/../Security/ignorelist.cfg
    [20:06:19] Loading ignorelist failed - file missing or corrupt. A blank ignorelist file will be generated for you.
    [20:06:19] Config file not found '/root/../Security/seclevs.cfg'
    [20:06:19] Loading security levels from Base/../Security/seclevs.cfg
    [20:06:19] Loading default security levels
    [20:06:19] Loading game rules from Rules/WAR/gamemode.cfg...
    [20:06:19] Loaded team 0 'Blue Team'
    [20:06:19] Loaded team 1 'Red Team'
    [20:06:19] Adding map to cycle 'Maps/WAR/Juggernaut.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/DaviesPlains.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/MurkshireHills.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/Jungle.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/MiddleIsland.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/BlademireRidge.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/Islands.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/Crises.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/EarthMoving.png'
    [20:06:19] Adding map to cycle 'Maps/WAR/Aug17/8x_HawksCieza.png'
    File open error: No such file or directory
    
    [20:06:20] LOADING WAR PNG MAP Maps/WAR/Juggernaut.png
    [20:06:20] ### Setting WAR Scrolls
    [20:06:22] Match not found for file /GUI/InteractionIcons.png
    [20:06:23] ############ GAMEMODE WAR
    [20:06:23] Match not found for file ArcherMale.png
    [20:06:23] Could not open file of image: ArcherMale.png
    [20:06:23] Match not found for file ArcherFemale.png
    [20:06:23] Could not open file of image: ArcherFemale.png
    [20:06:23] Match not found for file TeamPalette.png
    [20:06:23] Could not open file of image: TeamPalette.png
    [20:06:23] Could not open file of image: TeamPalette.png
    [20:06:23] Could not open file of image: TeamPalette.png
    [20:06:23] Could not open file of image: TeamPalette.png
    [20:06:23] Match not found for file KnightMale.png
    [20:06:23] Could not open file of image: KnightMale.png
    [20:06:23] Match not found for file KnightFemale.png
    [20:06:23] Could not open file of image: KnightFemale.png
    [20:06:23] Match not found for file BuilderMale.png
    [20:06:23] Could not open file of image: BuilderMale.png
    [20:06:23] Match not found for file BuilderFemale.png
    [20:06:23] Could not open file of image: BuilderFemale.png
    [20:06:23] Not using shaders. Not adding hq2x
    [20:06:23] Restarting rules script: Rules/WAR/Scripts/WAR.as
    [20:06:23] Checking any holidays...
    [20:06:24] Match not found for file MigrantMale.png
    [20:06:24] Could not open file of image: MigrantMale.png
    [20:06:24] Match not found for file MigrantFemale.png
    [20:06:24] Could not open file of image: MigrantFemale.png
    [20:06:26] NO PLAYERS - SERVER PAUSED (to change this behaviour set /sv_canpause 0
    
    I haven't changed any settings except for the server name, description and game mode in autoconfig.cfg and set myself as a superadmin in superadmin.cfg. Every .example is removed in the Security folder (although I think that it's not important for my issue).

    Only the Juggernaut.png map is available on the server. Whenever I try to force a map chance, it always loads this one again. And yes, I'm sure I'm not clicking restart instead of next.

    Also the part of the code that starts at 20:06:22 seems weird to me, I don't think it should happen.

    I'm totally lame at Linux, could it be some screwed up permissions? Maybe KAG cannot access those files?
     
    Last edited: Sep 26, 2017
    kaizokuroof likes this.
  2. kaizokuroof

    kaizokuroof Agkubuk|'Kaizokuroof' Cilobakil, Roofpointy Global Moderator Forum Moderator Donator Tester
    1. PumpkinStars - [Pk#] - Inactive

    Messages:
    909
    Hi, really late reply! Thanks for your thread, I'll lock it so no future replies can be made, but it's great you fixed your problem and let us know. I'll mark it as locked, so if someone else has the same issue, they might be able to solve it by viewing this thread.
     
    makmoud98 likes this.
Thread Status:
Not open for further replies.